‘twitter/bootstrap/bootstrap.less’ wasn’t found solution

If you’re installing twitter-bootstrap-rails 3.x on Rails 4.x.x and running into the following error:

‘twitter/bootstrap/bootstrap.less’ wasn’t found

First, remember that Rails 4.x has removed the :asset group from the Gemfile syntax, so if you’re using the group :assets, you can simply remove the gems from the assets group and it should work.

In my case, I initially loaded a new rails application with 4.0.x, then upgraded to 4.2.5, without also upgrading the sass-rails version from 4.0.2 to 5.0. ┬áIf you’ve removed the gems from the assets group, still running into the same error above, and your situation is similar, then try updating your Gemfile’s sass-rails line to:

gem 'sass-rails', '~> 5.0'

 
Then

bundle update sass-rails

 
to get the latest version.

Leave a Reply

Your email address will not be published. Required fields are marked *